Jump to content
  • 0

Echo problem


Ultra Fatality
 Share

Question

I'm back and i think this is my last problem for awhile so basically what happens is when you or p2 hit a certain life point this danger theme plays now everything works just fine its just that it has this one problem it repeats the sound everytime you enter a different state i have no idea why its doing that so im completely lost here and i think thats the only thing wrong with it heres my code

 

Stop the normal stage music from playing

 

[state -3, AssertSpecial]

type = AssertSpecial

trigger1 = time < 100000000 && life < 100

;trigger1 = stateno = [0,5000]

flag = nomusic

ignorehitpause = 1

persistent = 1

 

Danger theme that repeats itself everytime i go into a diffferent state

 

[state -3, PlaySnd]

type = PlaySnd

trigger1 =time=1&&life<100&&StageVar(info.name)="Wasteland"

value = S6000,0

volumescale = 30

channel = -1

loop = 1

 

and i use this stop snd to help fix it but nothing worked

 

[state 0, StopSnd]

type = StopSnd

trigger1 = time = 0

channel = -1

;ignorehitpause =

;persistent =

 

well i hope this help you guys help me because this is the last thing im stuck on before i can keep moving

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Use vars then.
 
[state -3, PlaySnd]
type = PlaySnd
trigger1 =time=1&&life<100&&StageVar(info.name)="Wasteland"
trigger1 = var(#) = 0
value = S6000,0
volumescale = 30
channel = -1
loop = 1
 
[state -3, VarSet]
type = VarSet
trigger1 =time=1&&life<100&&StageVar(info.name)="Wasteland"
var(#) = 1

 

Replace # with a number (I suggest 10 because it's a nice number), and this should work. If it doesn't, try shifting it into State -2.

Link to comment
Share on other sites

  • 0

Use vars then.

 

[state -3, PlaySnd]

type = PlaySnd

trigger1 =time=1&&life<100&&StageVar(info.name)="Wasteland"

trigger1 = var(#) = 0

value = S6000,0

volumescale = 30

channel = -1

loop = 1

 

[state -3, VarSet]

type = VarSet

trigger1 =time=1&&life<100&&StageVar(info.name)="Wasteland"

var(#) = 1

 

Replace # with a number (I suggest 10 because it's a nice number), and this should work. If it doesn't, try shifting it into State -2.

 

nope it echoed worst and it did the opposite thing and stop playing when you go into a different state

Link to comment
Share on other sites

  • 0

I suggest you to use a Helper state controller that contains the PlaySnd state controller.  Then call the Helper somewhere in StateDef -2 or StateDef -3 or wherever you want it to use that.  You may want to use triggerall = NumHelper(###) when the Helper is being called...........

Hope this way might work for you.

Link to comment
Share on other sites

  • 0

I suggest you to use a Helper state controller that contains the PlaySnd state controller.  Then call the Helper somewhere in StateDef -2 or StateDef -3 or wherever you want it to use that.  You may want to use triggerall = NumHelper(###) when the Helper is being called...........

Hope this way might work for you.

 

it sorta worked but now the nomusic assertspecial isn't working right same thing enter a different state it plays a bit before shutting off again and repeating

Link to comment
Share on other sites

  • 0

Just tried that exact code and it worked. The only way I managed to get it to not work was placing it in State -3, so try placing it in State -2.

i got the sound to stop echoing but now the assertspecial is having a reserves effect in which everytime i enter a different state it plays for a second and then shuts off and repeats everytime i enter a different state

Link to comment
Share on other sites

  • 0

Nope. Tried it with AssertSpecial in State -2 and it still worked.

 

On a side note, change "time < 100000000" to "1". Not "time < 1", just "1". It won't fix the problem, but it's better.

 

This is the exact code I have in State -2:

[state -2, AssertSpecial]
type = AssertSpecial
trigger1 = 1 && life < 100
flag = nomusic
ignorehitpause = 1
persistent = 1
 
[state -2, PlaySnd]
type = PlaySnd
trigger1 = time = 1 && life < 100 && StageVar(info.name) = "Wasteland"
trigger1 = var(10) = 0
value = S6000,0
volumescale = 30
channel = -1
loop = 1
 
[state -2, VarSet]
type = VarSet
trigger1 = time = 1 && life < 100 && StageVar(info.name) = "Wasteland"
var(10) = 1

Link to comment
Share on other sites

  • 0

 

Nope. Tried it with AssertSpecial in State -2 and it still worked.

 

On a side note, change "time < 100000000" to "1". Not "time < 1", just "1". It won't fix the problem, but it's better.

 

This is the exact code I have in State -2:

[state -2, AssertSpecial]
type = AssertSpecial
trigger1 = 1 && life < 100
flag = nomusic
ignorehitpause = 1
persistent = 1
 
[state -2, PlaySnd]
type = PlaySnd
trigger1 = time = 1 && life < 100 && StageVar(info.name) = "Wasteland"
trigger1 = var(10) = 0
value = S6000,0
volumescale = 30
channel = -1
loop = 1
 
[state -2, VarSet]
type = VarSet
trigger1 = time = 1 && life < 100 && StageVar(info.name) = "Wasteland"
var(10) = 1

 

 

ok so did it work on yours because im trying it right now to see remember it only plays for a second everytime i enter a different state so u should just move like crazy and see if u can hear your normal music play at all

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...