Jump to content
  • 0

Can't load SFF problem in Mugen 1.1


Krypto 'SAM' saiyaN
 Share

Question

Why this problem happen actually? Sometimes I get this trouble, can happen to both characters and stages..even the lifebars sometimes happen, usually if the sff file for that stuff is above 100mb. Why? Is this because I don't have enough RAM? My RAM is only 4gb. Or it because of the graphic card? We all know in mugen 1.1, for those who use the 'older graphic card' must set safemode = 1. What is the new graphic card actually??? I'm not really good with all this stuff.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I can tell when more complicated next-gen fighting games' materials are released, the SFFs and SNDs can only grow bigger every now and then (provided that someone cares to do these jobs)!

Of course, one might just add as many things as he/she/it wants to the SFFs and SNDs, regardless the source origin.

All of my leisure money has been spent on my PC because it is my only entertainment system so yes, please upgrade your PC hardware if necessary and affordable.

Link to comment
Share on other sites

  • 0

It's just something that happens.  My hardware is much better than the average MFFAer (which doesn't require much effort) and I still get this error.  Mugen is a 32-bit program, so it can only use 2GB of system RAM and 2GB of GPU RAM.  Mugen is exceptionally poor at managing its own memory usage,

Link to comment
Share on other sites

  • 0

This is why I said a PC hardware upgrade helps:

 

VwKK9yY.png

* in my Fighter Factory 3

=> sf4omni.sff file size is 236MB

 

And, sf4omni runs smoothly in my MUGEN1.1 and MUGEN1.0

 

For your case:

 

MWoIcHc.png

* in my Fighter Factory 3

=> Kukulkan.sff file size is 130MB

 

aBuBgff.png

* in my MUGEN1.1

=> my MUGEN1.1 video setting:

;-------------------------------------------------------



;Screen rendering mode.
;OpenGL - Experimental OpenGL renderer (recommended)
;System - default SDL rendering mode (e.g. windib in Windows)
;DirectX - DirectX 5 renderer
;System and DirectX modes do not support advanced features
;such as RGB sprites and window resizing.
RenderMode = OpenGLScreen ;System

;Set to 1 to enable "safe" mode for older graphics cards.
;Many features will be disabled.
SafeMode = 0

;The video resolution defaults to the same as the game resolution.
;In windowed mode, this specifies the window size.
;You can force an alternate resolution by uncommenting the lines
;below.
;Width = 1280
;Height = 720

;This is the color depth at which to run MUGEN.
;Ignored if RenderMode=System (forced to 16).
Depth = 32

;Set to 1 to enable vertical retrace synchronization.
;Only supported for RenderMode=OpenGL.
VRetrace = 0

;Set to 1 to start in fullscreen mode, 0 for windowed.
;This enables exclusive fullscreen, which may give better performance
;than windowed mode.
FullScreen = 0

;Set to 1 to make the window resizable when in windowed mode.
;Only supported for RenderMode=OpenGL and OpenGLScreen.
Resizable = 1

;Set to 0 to stretch the video to fit the whole window.
;Set to 1 to keep a fixed aspect ratio.
KeepAspect = 0

;Drawing mode
;Choose from Normal (fast) and PageFlip (less image "tearing")
;BlitMode is ignored for RenderMode=OpenGL
BlitMode = PageFlip;Normal

;Stage fit mode.
;0 - stage drawn to width of screen (may crop stages with tall aspect)
;1 - stage shrunk to fit into screen
;Ignored if RenderMode=System (forced to 0)
StageFit = 1

;System fit mode.
;0 - system drawn to width of screen (may crop motifs with tall aspect)
;1 - system shrunk to fit into screen
;Ignored if RenderMode=System (forced to 0)
SystemFit = 1

 

kO75KKH.png

* in my MUGEN1.0

=> my MUGEN1.0 video setting:

;-------------------------------------------------------



;The video resolution defaults to the same as the game resolution.
;You can force an alternate resolution by uncommenting the lines
;below.
;Width = 1280
;Height = 720

;This is the color depth at which to run MUGEN.
;Only 16 is supported at this time.
Depth = 16

;Set to 1 to enable vertical retrace synchronization. Do not enable
;if BlitMode = PageFlip.
;Not supported in 1.0.
VRetrace = 0

;Set to 1 to enable fullscreen mode, 0 for windowed.
FullScreen = 0

;Drawing mode
;Choose from Normal (fast) and PageFlip (less image "tearing")
BlitMode = PageFlip;Normal

;Screen rendering mode.
;System - default SDL rendering mode (e.g. windib in Windows)
;DirectX - DirectX 5 renderer
;OpenGLScreen - hack that allows window resizing but could be slow
RenderMode = OpenGLScreen;System

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...