Jump to content
  • 0

Pallette didn't work.


Krypto 'SAM' saiyaN
 Share

Question

12 answers to this question

Recommended Posts

  • 0

1.0 SFF is SFF2. supports 32bit images. however it needs to be indexed. works on mugen 1.0 and 1.1.

 

1.1 SFF is SFF2. supports 32bit images. does not need to be indexed. works on mugen 1.1 ONLY.

 

IF you are adding palette's your need to save it as whatever the SFF was originally. and in most cases it will NEVER ask you the option of saving type, unless you make a new sprite file.

Link to comment
Share on other sites

  • 0

Well I still don't understand how to solve it. I know about the pals being group 1 and index 1-12. The problem is now it's about the existing pals with doesn't work anymore after I save the sprites to 1.1. I have to do that because I add the PNG custom port, so the sprites have to be save as 1.1, if not the custom port will have a white background in mugen. I always overwrite the sff file when I save as 1.1. After that, only pallette 1 are okay, another pals are disable. I have 8 pals on the character and after save as 1.1, only first pals which is usable, the other 7 pals are cannot be use even though they still have when I open it in fighter factory again. This make even I add the new pals, it's wont work. Still, only first pals which can be use.

Link to comment
Share on other sites

  • 0

I've never tried this, but whatever.  It's better to blind guess a fix than just say "lol, don't use 1.1".  I'll assume you're using Fighter Factory 3, because you'd pretty much have to be.

 

STEP 1) If it isn't already, make the sprites for your character use palette 1,1.  It should already be doing so, but 0,0 also works, so that could cause a problem.

 

If the character doesnt already contain a palette 1,1 you'll have to add it.  So add the default palette and call it 1,1. (Palettes -> Add)

Then, go to the advanced palette editor, change the first sprite (such as 0,0) to palette 1,1 and hit apply to current sprite.

If/When it asks about which palette to use, go ahead and specify 1,1.  Or, if you're feeling lucky, hit ignore.

 

If you had to perform the above, then use "Palettes -> Apply to Sprites" (or apply to groups) to make sure that every sprite is using the correct palette.  BE CAREFUL

 

STEP 2) Add the rest of the character's palettes to the SFF.

 

So yeah, now you're going to add every other palette into the SFF with "Palettes -> Add".  So the second palette is 1,2 and so on all the way to 1,12 if you want.  Actually, you can add however many you want, but you'll need that dumb palette selector code to use anything over 12.

 

STEP 3) Make sure you're not missing the patently obvious.

 

Make sure your DEF has "pal.defaults = 1,2,3,4,5,6,7,8,9,10,11,12" and your [palette keymap] is set up how you want.

Link to comment
Share on other sites

  • 0

mugen 1.0 and 1.1 SUPPOSEDLY doesnt support

 

pal.default = 1,2,3,4,5,6,7,8,9,10,11,12

 

at least thats what it says. only 1 ~ 4.

 

and the reason I asked was because SFF2 in 1.1 will not work in 1.0.

Link to comment
Share on other sites

  • 0

I have that problem so its npt just you, and even I dont know. Just randomly some work and some dont.

For me, it effect all characters that I save as 1.1. I notice it when I press another button to change the pals and when the game start, the pals is same like the first pals. So I check to all characters that I have save as 1.1 and it does to all. I guess maybe this has no solution because like Ryon said, only stages, screenpack and for lifebars too that using 1.1 sff properly. For characters, it will be not...I mean, there was too many characters out there, nobody will update it to 1.1 version.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...